Linux Wireless Card Config Instructions

Intro, intermediate and advanced HOWTOs and discussion.

Linux Wireless Card Config Instructions

Postby weazy » Fri Aug 08, 2003 10:51 am

Note: these instructions were written for gentoo, the only gentoo specific reference here is 'emerge' you can replace that with compile. unmerge is where you remove all references to the program. RPM has similar commands.

I spent a gawd awful amount of time figuring this out on my machine so I thought I would post those things that I found worked in other posts in one comprehensive Tip for Dell users.


System Specs
I am using a Dell Inspiron 1100 with a Netgear MA401RA
Originally, I chose this dell cuz it was big bang for the buck and all the components were supported by Linux.

I started off with an Orinoco Gold card, which if you look at my history of posts was a major undertaking on this Dell computer. I ended up sending it back because I never could get it to work. I concluded that the new Orinoco Gold cards use a different chipset, not the original HERMES, but rather HERMES2 which according to a Netgear Rep, doesnt work with the old drivers. If you want to get into an Orinoco Gold card taht does work you have to make sure it says Orinoco Gold Classic or is and old card. This divition of Lucent, which was divested into Agere was eventually bought by Proxim who changed the chipset.

I saw a bunch of posts on the MA401RA so I decided to go with that.


MA401RA
By the time I tried installing and configuring this beast, I had already spent a ton of time changing things around with the Orinoco card. So after spending another 3 hours trying to undo all my changes I did the following:

1. I deleted /etc/pcmcia totally.
2. emerge unmerge pcmcia-cs
3. emerge unmerge linux-wlan-ng (I went down this road wtih both cards, it was a bust with both)

make.conf use variables should have these:
pcmcia cardbus

so that got me back to an unconfigured system. The next step make sure the kernel is set up properly. I use the following set up:

code:
General setup > PCMCIA/CARDBUS support
nothing selected

PCI Hoplug support > Support for PCI Hotplug <*>

Network Device support > Wireless LAN (non-hamradio) [*]

thats it pertaining to wireless.

recompile if necessary:

make dep && make clean bzImage modules modules_install
cp /boot/bzImage /boot/bzImage.old
cp arch/i386/boot/bzImage /boot/bzImage
/sbin/lilo
mount /dev/hdc1 /boot

now you need to emerge pcmcia-cs.
emerge pcmcia-cs

add pcmcia to default runlevel
rc-update add pcmcia default

add modules to modules.autoload
ds
i82365

you need wireless tools
emerge wireless-tools

I did a reboot here, but I do not think its necessary.

when your computer comes back up do an lsmod or /sbin/lsmod (depending on if you are root or sudo) and make sure the appropriate modules loaded. If you are using MA401RA they are:

orinoco_cs
orinoco
hermes
ds
i82365
pcmcia_core

note: I only have ds and i82365 in modules.autoload the rest load as a result.

I read in another tips article to do this, I don't know if it was necessary but i did it anyway:

env-update
source /etc/profiles
ldconfig
update-modules force

Dell Weirdness
I found instructions on this forum about editing /etc/pcmcia/config.opts

on the line
include port 0x100-0x4ff.....
delete the range: 0x800-0x8ff

I never saw that had to be done for my chipset or brand of Dell (Inspiron 1100 P4 2.0 GHZ), but I found it HAD to be done, so make sure you do it too.

WEP
I use a 64 bit WEP key which I think is a baseline amount of security, as in, you should AT LEAST have this.

the way i set my WEP key is like so:
iwconfig enc on
iwconfig eth0 key 1111111111

Roamer
you could commit these changes to the auto file, but I need it to be more flexible since I am on many different wireless networks on a weekly basis.
The way I handle that is:

once I boot and PCMCIA comes up, the basics are configured automatically, the network specific stuff I keep in a script, one script for each network situation like so:

script name: home.wirex
iwconfig essid home;
iwconfig eth0 key 1111111111;
ifconfig eth0 up;
dhcpcd eth0;

I have my built-in NIC set up as modules and set to eth1. I DO NOT have the modules autoload since it's more likely I will be running a wireless connection on my laptop and I don't like unused modules running. I wrote a short script for eth1 that I run when I want to enable that interface.

the script is stupidly simple:
/sbin/modprobe bcm4400
/etc/init.d/net.eth1 start
/etc/init.d/netmount start

that script has 0700 perms so I sudo it.

I hope this was helpful.
--The Devil is in the Details--
User avatar
weazy
Ex-Admin
 
Posts: 1688
Joined: Sun Jul 07, 2002 10:02 am
Website: http://www.hackerthreads.org
Location: any given

Return to ā€œ%sā€ Linux & BSD Tutorials

Who is online

Users browsing this forum: No registered users and 0 guests

cron